Citrix Web Interface displays 'The system configuration is invalid or unavailable'

Author: NetworkAdminKB.com
Created: 2008-09-23
Modified: 2008-11-20

Issue:

Users report that Citrix Web Interface displays The system configuration is invalid or unavailable. Please contact your system administrator when they attempt to access the web site.

 

The server that hosts the Citrix Web Interface also has the following events in the Application Event Log.

 

Event ID: 0

Source: Web Interface at C:\Inetpub\wwwroot\CitrixWeb\Citrix\AccessPlatform

Category: None

Description:

All of the configuration services failed. Waiting to try again. [Log ID: 730ee017]

 

Event ID: 0

Source: Web Interface at C:\Inetpub\wwwroot\CitrixWeb\Citrix\AccessPlatform

Category: None

Description:

Could not communicate with the configuration service "w.x.y.z(80)".  If necessary, correct the address in the bootstrap.conf file. [Log ID: c028c72d]

 

 

The server that is specified as the IP Address “w.x.y.x(80)” that host has the following error in the event logon.

 

Event ID: 534

Source: Security

Category: Logon/Logoff

Description:

Logon Failure:

                Reason:   The user has not been granted the requested

                                logon type at this machine

                User Name:             Ctx_ConfigMgr

                Domain:                   SERVER1

                Logon Type:            4

                Logon Process:       DCOMSCM

                Authentication Package:         Negotiate

                Workstation Name:  SERVER1

                Caller User Name:    SERVER1$

                Caller Domain:         DOMAIN1

                Caller Logon ID:       (0x0,0x3E7)

                Caller Process ID:    744

                Transited Services:  -

                Source Network Address:        -

                Source Port:            -

 

Cause:

The Ctx_ConfigMgr user requires both the logon as service and logon as batch job rights on the specified Citrix server.  The Logon Type field in the descript displays which permission the logon is failing on.

 

Below is a list of valid Logon Type codes that can be displayed.

Logon Type 2 – Interactive

Logon Type 3 – Network

Logon Type 4 – Batch

Logon Type 5 – Service

Logon Type 7 – Unlock

Logon Type 8 – NetworkCleartext

Logon Type 9 – NewCredentials

Logon Type 10 – RemoteInteractive

Logon Type 11 – CachedInteractive

 

Solution:

1)      Determine type of logon that is failing for the Ctx_ConfigMgr user id.

a.       Review the description of Event ID 534 for the Logon Type specified.

2)      Review the Local Security Policies…User Rights Assignments

a.       Default Settings on a Citrix Metaframe 4.x Server

                                                               i.      Log on as batch job

 

                                                             ii.      Log on as Service

 

b.      Add Ctx_ConfigMgr to the appropriate right

Article ID: 104, Created On: 9/17/2011, Modified: 9/17/2011