How to enable or disable VMWare HA on an ESX 3.x Cluster

Author: NetworkAdminKB.com
Created: 2009-01-11
Modified: 2009-01-11

Issue:

After upgrading VirtualCenter Server reconfiguration of HA Agent on an ESX Host fails.

 

One or more ESX Hosts may show the following error(s) in Tasks and Events

            HA agent has an error

            Unable to contact a primary HA agent in cluster [name] in [datacenter]

 

Right clicking the ESX Host and Selecting Reconfigure for VMWare HA, does not correct the issue with the HA Agent on the affected ESX Hosts.

 

Cause:

This is a known issue that occurs after upgrading VirutalCenter Server and is listed in the Release Notes for the upgrade.  Below is an excerpt from the Release Notes for VirtualCenter Server 2.5u3.

 

Reconfiguration of HA Agent on an ESX Server Host Might Fail After VirtualCenter Server Is Upgraded
When a VirtualCenter Server that contains an HA-enabled cluster is upgraded, and ESX Server hosts are reconnected to the VirtualCenter, reconfiguring the HA agent of one of the ESX Server hosts might fail with an HA agent error message similar to the following:
HA agent on <Host_Name> in cluster <Cluster_Name> in <Datacetner_Name> has an error:
cmd addnode failed for primary node: /opt/vmware/aam/bin/ft_startup failed

Workaround: After upgrading the VirtualCenter Server, disable and re-enable HA on the cluster.

 

Solution:

1)      Using the VI Client connect to the VirtualCenter Server

2)      Right Click the Cluster Name

a.       Select Edit Settings

b.      Uncheck Enable VMWare HA

c.       Click OK

d.      Wait as the HA services are stopped and removed from the ESX Hosts

3)      Right Click the Cluster Name

a.       Select Edit Settings

b.      Check Enable VMWare HA

c.       Click OK

d.      Wait as the HA services are added and started to the ESX Hosts

 

 

More Information:

VirtualCenter 2.5u3 Release Notes

Article ID: 125, Created On: 9/17/2011, Modified: 9/17/2011