Issue:
A snapshot was not properly removed and/or hung during the removal process. The virtual machine is now in an unusable state.
Cause:
The cause of the snapshot failing may vary by configuration.
Solution:
You should perform the following actions to manually remove the Snapshots from the Virtual Machine (VM)
1) On the ESX Host run the following command
a. service mgmt-vmware restart
i. This will stop the hung snapshot removal process
ii. This will most likely cause the VM to be labeled as “inactive” in VirutalCenter

2) In VirtualCenter do the following
a. Right click the “inactive” VM and select Remove from Inventory
3) Using the Datastore Browser do the following
a. Browse to the folder of the VM files
b. Rename all VMSN files to VMSN.OLD
c. Rename all VMSD files to VMSD.OLD
4) On the ESX Host you will need to do the following.
a. Change to the folder that holds all the VM files
b. Copy the VMX File to VMX.OLD
i. cp name.vmx name.vmx.old
c. Modify the VMX file using NANO
i. Command: nano name.vmx
ii. Change the “SCSIx:y.fileName =” lines to point to the original VMDK filenames
1. Example Original VMDK filename: name_1.vmdk
2. Example Snapshot VMDK filename: name_1-000001.vmdk
iii. Save the VMX file
1. Ctrl – O then Enter
iv. Exit Nano
1. Ctrl – X
5) Add the VM back to the VirtualCenter Inventory
a. Using the Datastore Browser
i. Right click the VMX file and select Add to Inventory
ii. Follow the wizard