Issue:
The following error occurs when deploying a template, cloning a virtual machine, or performing other actions on virtual machines.
Failed to connect to host

Cause:
The IP Address of the Service Console was changed while connected to the VirtualCenter Server. VirtualCenter only updates the IP Address of the ESX/ESXi host when the host is added (or manually disconnected and reconnected).
If you change the IP Address of the ESX/ESXi host while connected to VirutalCenter the change is not recorded in the VirtualCenter database. Therefore, VirtualCenter will attempt to manage the ESX/ESXi host using the wrong IP address.
Solution:
To prevent these issues you should always change the IP Address of the Service Console while disconnected (or removed) from the VirtualCenter server.
Method 1
To correct these issues you can remove (or disconnect) the ESX/ESXi host from VirtualCenter and then reconnect (or re-add) the host. This will place the correct IP address in the VirtualCenter database and update the associated VC agent configuration file (/etc/opt/vmware/vpxa/vpxa.cfg).
I would try disconnecting the host first, then if that does not work, remove and re-add the ESX/ESXi host.
Method 2
1) Stop VirtualCenter Service
2) Update the VC Server database to the correct IP Address.
UPDATE [VIM_VCDB].[dbo].[VPX_HOST]
SET IP_ADDRESS = 'w.x.y.z'
WHERE DNS_NAME = 'dns.domain.com'
a. See More Information on to view the current DNS_NAME and IP_ADDRESS settings.
3) Start VirtualCenter Service
4) The /etc/opt/vmware/vpxa/vpxa.cfg need not be edited on the host. Once you restart the VirtualCenter Service the vpxa.cfg is updated correctly.
More Information:
You can run the following query on the VirtualCenter database to view the current IP Addresses of all ESX/ESXi hosts.
select dns_name, ip_address from VPX_HOST