Issue:
You receive the following error message when VirtualCenter (VC) attempts to communicate with an ESX or ESXi server.
Unable to contact the specified host
Cause:
The VirtualCenter agent (vpxa) needs to be restarted.
Solution:
ESX
Login as root to the server console
Restart the VC agent (vmware-vpxa) using the following command
service vmware-vpxa restart
If the problem still persists remove and reinstall the VC agent on the ESX host.
1) Remove the ESX Host from VC
a. In the VI Client right click the ESX host and select Remove
b. This should remove the agent, if not you can remove it manually.
2) Manually remove the VC Agent from the ESX host using the following commands on the ESX console.
a. Find current VC Agent version
rpm –qa |grep vpxa
i. If nothing is returned the agent was removed successfully.
b. Stop the Host Agent (mgmt-vmware)
service mgmt-vmware stop
c. Stop the VC Agent
service vmware-vpxa stop
OR
/etc/init.d/vmware-vpxa stop
d. Uninstall the VC agent by version returned earlier
rpm –e VMware-vpxa-2.5.0-104215
i. Expect the following:
warning: /etc/vmware/vpxa.cfg saved as /etc/vmware/vpxa.cfg.rpmsave
e. Verify the VC agent has uninstalled
3) Add the ESX host back into the VirtualCenter Server.
ESXi
Select Restart Management Agents from the Customize System menu
Article ID: 205, Created On: 9/18/2011, Modified: 9/18/2011
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