Telnet Server responses with 'Connection to host lost' to Telnet Clients

Author: NetworkAdminKB.com
Created: 2009-11-13
Modified: 2010-02-06

Issue:

Only members of the Administrators group can logon to the Telnet Server.  When a user that is a member of the TelnetClients group tries to logon they receive the following message immediately following a successful logon.

 

Connection to host lost.

 

Cause:

The default command shell may be restricted, or accessing a file that is restricted to only Administrators of the computer.

 

Solution:

Download and use Process Monitor from Sysinternals / Microsoft to troubleshoot the issue.

 

1)      Start Process Monitor

2)      Try and logon with the problem user id.

3)      Stop the Log on Process Monitor

4)      Search the Log for “Denied” in any files referenced by the Default Shell

5)      Change the security as needed to allow the TelnetClients group or User group access.

 

The default shell is normally cmd.exe by can be changed by specifying a new command shell this registry setting.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TelnetServer\1.0\DefaultShell

 

Article ID: 230, Created On: 9/18/2011, Modified: 9/18/2011