How to fix Cannot open VMX file device or resource busy

Author: NetworkAdminKB.com
Created: 2009-12-17
Modified: 2009-12-17

Issue:

One or more guests are not responding.  After powering the guests off you are unable to power the servers back on.  While attempting a power on you receive the following error.

 

Cannot open file “vmfs/volumes/GUID/folder/file.vmx” Device or resource busy.  Cannot open configuration file “vmfs/volumes/GUID/folder/file.vmx”

 

 

Multiple guests running on the same LUN are usually affected, but not all guests are usually identified at this point.

 

Cause:

The exact cause is unknown, but it appears that one or more guests may be over loading the LUN with activity.



Solution:

Use the VI Client to do the following

1)      Review the Summary tab of the affect guest for the following

a.       The ESX host

b.      The LUN the guest resided on

2)      Browse the LUN/Database to determine all possible guests that are affected.

a.       Click the ESX Host

                                                               i.      Click the Configuration tab

                                                             ii.      Click Storage on the left pane

                                                            iii.      Right Click the LUN

1.      Select Browse Datastore

3)      Attach to the Console of each guest to determine if it is responding

a.       Guests that are not responding should be powered off

b.      Guest that are responding can remain on.

4)      Once all affected guests are powered off, you may power them back on without issue.

 

If after powering off all affected guests disk activity does not return to normal, you should shut down the remaining guests that were responding earlier.  If this is the cause the guests that were left on should be investigated to determine why they are over utilizing the LUN.

Article ID: 320, Created On: 9/19/2011, Modified: 9/19/2011