How to fix Virtual Hard disk is a mapped direct-access LUN that is not accessible

Author: NetworkAdminKB.com
Created: 2011-02-12
Modified: 2011-03-08

Issue:

You receive the following error messages attempting to power on a VM.

 

Failed to find a host for powering on the virtual machine.  The following faults explain why the registered host is not compatible.

Virtual ‘Hard disk #’ is a mapped direct-access LUN that is not accessible.

 

If you attempt to Manage Path one of these selected Hard disks you receive the following error.

The is no multipath configuration for this LUN

 

Cause:

The Raw Data Mapping (RDM) vml.######################### assigned to the VM no longer matches the physical LUN assigned to the ESX Host.  This typically happens when the LUN was removed from then added back to the ESX Host.

 

This error may not occur until the VM or the ESX host was powered off.

 

Solution:

Use the following procedure to correct this issue.

1)      Record the settings of the bad LUNS

a.       Physical or Virtual RDM

b.      SCSI ID

c.       Associate LUN ID

                                                               i.      This you may need to get from documentation

2)      Remove the RDM LUNS from the VM

a.       Select Remove from virtual machine and delete files from disk

                                                               i.      This will remove the mapping file, but will not delete any data on the RDM.

3)      Remap the RDM LUNS in the VM

a.       Use the information recorded earlier.

4)      Power on the VM

Article ID: 349, Created On: 9/19/2011, Modified: 9/19/2011