Unable to power on VM after changing LUN IDs of RDMs

Author: NetworkAdminKB.com
Created: 2011-04-12
Modified: 2011-07-23


Issue:

You receive the following error message(s) after changing the LUN IDs of several LUNs presented to the ESX Hosts of a cluster.

 

Virtual disk ‘Hard disk #’ is mapped direct-access LUN that is not accessible.

 

There is no multipath configuration for this LUN.

When you attempt to Manage Paths

 

Cause:

The vml.############################## changed. 

 

This following may cause the vml.####################### number to change

1)      The RDM was only presented to a single ESX host, and it was removed from that host prior to it being presented to the other ESX hosts in the cluster

2)      The LUN ID used to present the LUN to the ESX Host has changed.

3)      Using third party tools to present LUNs as RDMs the VMs and associated ESX Hosts.   For example SnapDrive from Netapp has this ability.

4)      There may be other causes as well.

 

 

Solution:

 

You must remove all the RDM LUNs and re-present them to the VM.

Article ID: 366, Created On: 9/19/2011, Modified: 9/19/2011