Issue:
After installing VMWare you wish to change the IP address of the Service Console. While viewing the properties of the Service Console in the VMWare Infrastructure Client you see that the IP Address is grayed out so it cannot be changed.

Cause:
When using the VMWare Infrastructure Client there are two primary issues that need to be addressed when attempting to change the Service Console IP address.
1) A secondary Service Console must be available to temporarily provide Service Console access to the VMWare server. This new Service Console should be available through a secondary NIC.
2) A secondary NIC must used so the default gateway for the VMWare server can still be used while the IP Address of the Service Console is changed.
However, it is possible to change the Service Console IP Address via the Command Line directly from the keyboard of the ESX Host. This method will require a reboot, but it does not require a second NIC.
Both methods are out lined below.
Solution:
Method 1
Change the Service Console IP Address using the VMWare Infrastructure Client
1) Add a secondary Network Adapter and Service Console
a. Click the Configuration Tab
b. Click Networking under the Hardware list
c. Click “Add Hardware…” in the upper right of the screen
d. From the wizard select “Service Console”
i. Click Next
e. Select a different vSwitch / NIC than what the current Service Console is using.
i. Click Next
f. Enter an IP Address, Subnet Mask, VLAN, etc for the new Service Console
i. Click Next
g. Click Finish
2) Change the Default Gateway used by the VMWare server.
a. Click the Configuration Tab
b. Click the Networking from the Hardware list
c. Click the “Properties…” of the vSwitch that contains the original Service Console that needs to be modified.
i. Select the “Service Console”
1. Click Edit
ii. Click the Edit button for the “Service Console Default Gateway”
iii. From the “Gateway device” drop down select the new NIC to be used.
1. Click OK
iv. Click OK
v. Click Close
3) Change the original Service Console IP Address or delete the original Service Console.
a. Click the Configuration Tab
b. Click the Networking from the Hardware list
c. Click the “Properties…” of the vSwitch that contains the original Service Console that needs to be modified.
d. To Delete the original Service Console
i. Select the “Service Console”
1. Click Remove
2. Click Yes
e. To change the IP Address of the original Service Console
i. Select the “Service Console”
1. Click Edit
ii. Edit the IP Address settings as needed.
iii. Click OK
f. Click Close
4) Repeat Steps 2 and 3 as needed to remove secondary NICs and Service Console access.
Method 2
Change Service Console IP Address via the Command Line from the keyboard
1) Delete existing Service Console Switch
a. esxcfg-vswif -d vswif0
b. This will return a message about “nothing to flush” if successful
2) esxcfg-vswif -a vswif0 -p “Service Console” -i 10.10.10.10 –n 255.255.255.0
a. Change IP address and network mask as needed.
3) Update the Hosts file
a. cd /etc
b. vi hosts (edit hosts file)
c. ESC R (enter replace text mode)
d. Change the IP address of the host to the ip address just configured.
e. ESC (to stop editing)
f. ESC :wq! (to save file)
4) If the new IP Address is on a different network the default gateway will need to be changed
a. cd /etc/sysconfig
b. vi network (edit network file)
c. ESC R (enter replace text mode)
d. Change the GATEWAY=10.10.10.10 line as needed
e. ESC (to stop editing)
f. ESC :wq! (to save file)
5) Reboot the ESX Host
a. reboot